Skip to main content

Reply to this post | Go Back
View Post [edit]

Poster: Brak Date: May 26, 2007 10:53am
Forum: etree Subject: FLAC 1.1.2 vs 1.1.4


There have been some noises here and in other places about a FLAC upgrade being required by the archive. I wasn't fully convinced, since there shouldn't be an incompatibility between minor version upgrades, neither 1.1.3 nor 1.1.4 mentioned a format change in their release notes.

Someone got this off of the FLAC mailing list as well:


> all versions of FLAC are forwards-compatible
> unless the middle version number changes.
> So if it was, say, 1.1.4 versus 1.0.1, you might,
> possibly, have a problem. Both versions 1.1.x?
> No compatibility issue.

In order to confirm this, I took a show that had a FLAC CRC problem during derivation after upload to the archive. I compiled 1.1.4, latest tarball from sourceforge.

brak@ia340914:/2/items/rrfb2007-05-10$ ~/src/flac-1.1.4/src/flac/flac -v
flac 1.1.4

Got this error:
$ ~/src/flac-1.1.4/src/flac/flac -t rrfb2007-05-10d1t01.flac

flac 1.1.4, Copyright (C) 2000,2001,2002,2003,2004,2005,2006,2007 Josh
Coalson flac comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions. Type `flac' for details.

rrfb2007-05-10d1t01.flac: testing, 12% completerrfb2007-05-10d1t01.flac:
*** Got error code 2:FLAC__STREAM_DECODER_ERROR_STATUS_FRAME_CRC_MISMATCH


rrfb2007-05-10d1t01.flac: ERROR while decoding data
state = FLAC__STREAM_DECODER_READ_FRAME


Which matches the error we are getting with the version in
production... strangely also at th 12% mark.

/usr/bin/flac -t '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t01.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t02.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t03.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t04.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t05.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t06.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t07.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t08.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t09.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t10.flac' '/tmp/derive/rrfb2007-05-10/rrfb2007-05-10d1t11.flac'

flac 1.1.2, Copyright (C) 2000,2001,2002,2003,2004,2005 Josh Coalson
flac comes with ABSOLUTELY NO WARRANTY. This is free software, and you are
welcome to redistribute it under certain conditions. Type `flac' for details.


rrfb2007-05-10d1t01.flac: testing, 4% complete
rrfb2007-05-10d1t01.flac: testing, 8% complete
rrfb2007-05-10d1t01.flac: testing, 12% completerrfb2007-05-10d1t01.flac: *** Got error code 2:FLAC__STREAM_DECODER_ERROR_STATUS_FRAME_CRC_MISMATCH


rrfb2007-05-10d1t01.flac: ERROR while decoding data
state = FLAC__STREAM_DECODER_READ_FRAME


I hope this shows clearly that both 1.1.2 and 1.1.4 are detecting the same error at the same position, same file, same show.

The upgrade to a newer version will happen at some point, but the brokenness with a few shows is unrelated to the version changes.

Reply to this post
Reply [edit]

Poster: cousinkix1953 Date: May 27, 2007 5:06am
Forum: etree Subject: Re: FLAC 1.1.2 vs 1.1.4

I tried the new FLAC and went back to the old one myself because I'm used to version 1.1.2 and it works for me...

Reply to this post
Reply [edit]

Poster: Brad Leblanc Date: May 27, 2007 7:12pm
Forum: etree Subject: Re: FLAC 1.1.2 vs 1.1.4

The new version is certainly better, and it is recommended that you upgrade on your home machine. However, it takes a lot more time and work to upgrade the archive system - and since there are no compatibility issues right now we cannot justify prioritizing it. It's going to have to wait.

-Brad